Suitable host systems for CEDAR Trinity Enhance

Information correct on 1 November 2018.

CEDAR Trinity Enhance (released 2018)

Requires v11, v12, 2018 Ultimate (64-bit only)

Other hosts

VST 2 and VST 3 supported

OS X 10.9 onward

Windows 7 onward

 

BACK